CrashPlan for Small Business eCommerce [Unscheduled Maintenance]
Incident Report for Code42 Software, Inc.
Resolved
This incident has been resolved.
Posted Jan 22, 2020 - 16:46 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 22, 2020 - 14:44 CST
Investigating
Our billing partner Digital River is currently experiencing issues due to unscheduled maintenance. We are working with them to resolve the issue as quickly as possible.

You may experience issues updating your credit card, address information or paying for your subscription during this time.

We will update as soon as the issue has been resolved.
Posted Jan 22, 2020 - 10:53 CST
This incident affected: CrashPlan for Small Business Services (Subscription management and store).