CrashPlan for Small Business eCommerce Unplanned Maintenance
Incident Report for Code42 Software, Inc.
Resolved
Unplanned maintenance has finished. The account management functions are working as intended.
Posted 13 days ago. Sep 03, 2019 - 15:43 CDT
Identified
Our eCommerce provider is currently down due to unplanned maintenance. Features such as updating your billing information, accessing receipts and managing your subscriptions automatic renewal may not be available. Our vendor, Digital River, has been notified and is working to resolve the issue as quickly as possible.

Orders can still be placed, however there may be a short delay in receiving your confirmation. We'll update this page when we have received additional updates.
Posted 13 days ago. Sep 03, 2019 - 09:31 CDT
This incident affected: CrashPlan for Small Business Services (Subscription management and store).