CrashPlan for Small Business Subscription Management is Inaccessible
Incident Report for Code42 Software, Inc.
Resolved
This incident has been resolved.
Posted Feb 26, 2020 - 12:38 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 26, 2020 - 12:03 CST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 26, 2020 - 12:03 CST
Investigating
We are currently experiencing an issue with our CrashPlan for Small Business payment processor that may prevent you from accessing your account and billing information.
Posted Feb 26, 2020 - 08:31 CST
This incident affected: CrashPlan for Small Business Services (Subscription management and store).